Experian RTW - E-Visa's – Incident details

All systems operational

E-Visa's

Resolved
Operational
Started 10 months agoLasted 15 days

Affected

HR Portal

Operational from 4:08 PM to 9:56 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    The Home Office has recently made some updates to EU Exit E-visas. As a result, you may notice more visas being flagged for review in the HR portal, where they would normally have been auto-approved.

    We’re already working on updating our system to reflect these changes, and we’ll let you know as soon as the update is live.