The issue has been identified and was limited to ios devices. A new version of the app has been developed and tested, and has been pushed to the Apple Store for review and release. We will keep you updated on progress.
Thank you for your patience.
Identified
Identified
We are continuing to work on a fix for this incident.
Investigating
Investigating
We are aware of an issue some candidates may be experiencing when attempting to open a new check invite. We are investigating this and will update as soon as we can.